Cheap VPS & Xen Server

Residential Proxy Network - Hourly & Monthly Packages

How to install ruby-nio4r on Debian Unstable (Sid)

Install ruby-nio4r

Installing ruby-nio4r package on Debian Unstable (Sid) is as easy as running the following command on terminal:

sudo apt-get update
sudo apt-get install ruby-nio4r

ruby-nio4r package information

distro Debian Unstable (Sid)
section Main
name ruby-nio4r
version 1.1.0-1+b3
description Ruby library providing a selector API for monitoring IO objects
subsection ruby
website / celluloid / nio4r
maintainer Debian Ruby Extras Maintainers

Uninstall ruby-nio4r

To remove just ruby-nio4r package itself from Debian Unstable (Sid) execute on terminal:

sudo apt-get remove ruby-nio4r

Uninstall ruby-nio4r and it’s dependent packages

To remove the ruby-nio4r package and any other dependant package which are no longer needed from Debian Sid.

sudo apt-get remove --auto-remove ruby-nio4r

Purging ruby-nio4r

If you also want to delete configuration and/or data files of ruby-nio4r from Debian Sid then this will work:

sudo apt-get purge ruby-nio4r

To delete configuration and/or data files of ruby-nio4r and it’s dependencies from Debian Sid then execute:

sudo apt-get purge --auto-remove ruby-nio4r