Cheap VPS & Xen Server

Residential Proxy Network - Hourly & Monthly Packages

How to install ruby-puppet-syntax on Debian Unstable (Sid)

Install ruby-puppet-syntax

Installing ruby-puppet-syntax package on Debian Unstable (Sid) is as easy as running the following command on terminal:

sudo apt-get update
sudo apt-get install ruby-puppet-syntax

ruby-puppet-syntax package information

distro Debian Unstable (Sid)
section Main
name ruby-puppet-syntax
version 2.0.0-1
description Syntax checks for Puppet manifests, templates, and Hiera YAML
subsection ruby
website / gds-operations / puppet-syntax
maintainer Debian Ruby Extras Maintainers

Uninstall ruby-puppet-syntax

To remove just ruby-puppet-syntax package itself from Debian Unstable (Sid) execute on terminal:

sudo apt-get remove ruby-puppet-syntax

Uninstall ruby-puppet-syntax and it’s dependent packages

To remove the ruby-puppet-syntax package and any other dependant package which are no longer needed from Debian Sid.

sudo apt-get remove --auto-remove ruby-puppet-syntax

Purging ruby-puppet-syntax

If you also want to delete configuration and/or data files of ruby-puppet-syntax from Debian Sid then this will work:

sudo apt-get purge ruby-puppet-syntax

To delete configuration and/or data files of ruby-puppet-syntax and it’s dependencies from Debian Sid then execute:

sudo apt-get purge --auto-remove ruby-puppet-syntax