Cheap VPS & Xen Server

Residential Proxy Network - Hourly & Monthly Packages

Using and Customizing Templates in OpenOffice.org


I believe in using tools. And if the tools are easy to use and free, so much the better. That’s why I’m a big proponent of using templates. Templates are one of the best ways to save time, effort, and be sure that your documents are consistent when they need to be.

Templates make life easier when you use them for letters, documents, brochures, etc. but they really make life easier when you use them for labels. The spacing for your label documents has to be extraordinarily precise to make sure that the text is printed exactly where it needs to be—I’ve tried making my own and while it’s possible, it’s really not worth it. It’s not worth it because there are so many pre-existing templates to use instead.

There might be a few sheets of labels somewhere without a corresponding OpenOffice.org label template, but they’re rare. You can print on virtually any label sheets you want with the templates included in OpenOffice.org, and the templates from WorldLabel.

This article is about how to use the OpenOffice.org templates, in particular the WorldLabel templates, to print the labels you need. I’ll talk about how to download them, install them, use them as they are, and how to customize them with graphics and other features.

I’ll also touch on how to use the OpenOffice.org label wizard; you can use the label wizard each time, or save the template you create in the same template repository with your WorldLabel templates.

 

About WorldLabel

WorldLabel lets you download free templates in Word, PDF, and OpenOffice.org formats. For OpenOffice.org you can download label templates in .stw or .ott file format for Openoffice.org 1.1x and 2.0 version for Writer. You can look them up by the number on your Avery label sheet box or read the description. There’s a huge number of templates including those for CD and DVD, video, mailing, shipping, and diskettes, and with square or round corners. The templates are XML Open Document Format (ODF), Public Domain, licensed under GPL.

http://www.worldlabel.com/Pages/openoffice-template.htm

worldlabelwebsite

Downloading WorldLabel Templates

The first step, of course, is to get the templates onto your computer. First, make a directory where you’re going to put them. Create a directory at C:\labels or /home/labels, for instance, though you can put them wherever you want.

Next, go to the URL for OpenOffice.org templates.

  • Go to this URL, if you want letter-size templates (this is what you want in the US): http://www.worldlabel.com/Pages/openoffice-template.htm
  • Go to this URL if you want A4 sized templates: http://www.worldlabel.com/Pages/openoffice-a4.htm

Downloading a specific template

You’ll see a list of templates. Find the one you want, by its corresponding Avery number (this is printed on your box of Avery labels), by the dimensions, or by the name if you know the WorldLabel name.

downloadtemplates

To download the template, find the Download link, under the version you want. If you’re using the current version of OpenOffice.org, use the Download link under the 2.0 version for .ott files. Then right-click on Download and choose Save Target As.

When the dialog box appears, specify your labels directory that already made, and click Save.

downloadtemplatestodirectory

Repeat the downloading steps for any additional templates you want.

Downloading all templates for version 1.x

This is available only if you want to use templates in the old version. If you want to download all the templates at once, scroll to the bottom and find this link.

downloadwholezipfile

Click it; you’ll go to another site. You’ll need to click two or three more times on various icons that specify 1.0 labels, but you’ll eventually see this.

download10zipfile

Right-click on it just as you did for the other links and choose Save Target As. Save the file to your labels directory.

Once the file has been downloaded, right-click on the file in your labels directory and choose to extract the files.

Installing the Templates in OpenOffice.org

Once you’ve got the WorldLabel templates, you should add them to the template repository and tell OpenOffice.org where they are. Strictly speaking, you don’t have to do any of this, since you can simply choose File > Open and find the template file. However, OpenOffice.org has a specific way to organize templates which is easier to use once you’ve got it set up.

This applies to any template that you download, as well as any template that you create.

There are several ways to do this; I’ll show you three.

Copying

Copy your templates to the appropriate directory. The directory is <OpenOffice>\share\template\language

Just paste your directory of templates into that location.

copyto

Importing a single template

That other way was so easy, why bother with anything else? Good question. This approach is good if you want to just bring in a particular template and maybe put it in another category like “templates for the month-end reports.”

1. Choose File > Templates > Organize.

2. Select a category on the left. (If you need to create one, right-click on an existing category, choose New, and immediately type the name of the new category.)

3. Right-click on the category and choose Import Template.

importtemplate

4. Find the template and click Open.

5. The template will appear in the category.

importtemplate2

Pointing to a Directory of Templates Locally or on the Network

Why would you need yet a third way to point OpenOffice.org at your templates? If you’re a system administrator, you want to make things easy on yourself. Therefore you might want to put all the templates on the network and just point each user to them. Here’s how.

1. Put the directory of templates on the server.

2. Important: Create at least one subdirectory and put the templates there. It’s odd, but OpenOffice.org recognizes the subdirectories when you do it this way, but not the main directory. You’d have something like this:

subdirectories

3. Choose Tools > Options.

4. Go to OpenOffice.org > Paths and select the Templates line.

templatepath

5. Click Edit. In the window that appears, click Add. Specify the path on the network. Note that you can have several paths to templates.

selectpaths

6. Click OK, then click OK twice more to save changes and close the window.

Note: There’s another way to add a template to the repository, but it’s more useful when it’s a template you create yourself, or create based on one of the wizard templates. I’ll talk about that approach later.

Using WorldLabel Templates

Now that you’ve installed the templates, the rest is easy. Just choose File > New > Templates and Documents. You’ll see the templates window and your templates; if you don’t, select the Templates icon at the left.

templatewindow

Double-click the templates category you want, then select the template you want. Any information about the template will be displayed.

templatewindow2

Double-click the template; it will open, as shown.

blanktemplate

To add information, just click in the area where you want label information, and start typing. Press Return to go to a new line, then press Tab twice to go to the next label area.

labels_topline

To format text, just select one or more labels. To select all of the labels, click in the text for one, then press Ctrl A. Apply formatting as you would normally, either with the toolbar, or by choosing Format > Character or Format > Paragraph.

labelformatting

When you’re finished, just print and insert the correct sheet of labels in your printer.

Customizing a WorldLabel Template

You might be wondering how the WorldLabel templates are created, especially if you’ve used the wizard templates, which are based on Frames. The WorldLabel templates are created with tables; you don’t see the borders since they’ve simply been formatted that way. If you take a close look, though, when you click in the template, you can see the table toolbar.

labels_tabletoolbarattop

This means you have all the formatting capabilities that you normally get with a table, including the following.

  • Alignment to the top, middle, or bottom (you might want to align your labels all the top)
  • Background formatting; you can apply a color to the background of each cell
  • Easier cutting and pasting than with frames
  • Easier selection of all the content of a row, column, or the whole table
  • Easier copying and pasting; you can easily select the whole table and copy it onto the next page, to make multi-page sheets of labels

To apply values to the table, like backgrounds, choose Table > Table Properties and choose the appropriate tab.

tableproperties

To do things to the table, choose View > Toolbars > Table.

tablestoolbar

Showing and Hiding Table Borders

I find that it’s easier to work with, when you’re doing any extensive customization, if the borders are visible. To see the borders of the table, select the whole table. You can simply click in the upper right cell and drag down to the lower right cell, or click in one of the cells and press Ctrl A. Then click and hold down on the indicated borders icon in the Tables toolbar, and choose the lower right option for borders on all cells.

applytableborders

The table borders appear. As you can see there are actually five columns, including the two spacer columns.

applytableborders_result

To take the borders off later, just repeat those steps but choose the upper left option for no borders on any cells.

Pasting into Label Cells

Table-based label templates are much easier to paste content into. Let’s say you’ve just got a table somewhere else and you want to make labels out of it. Don’t worry about the dimensions of the original table. You will have to do some formatting once you’ve pasted, though, so this should be done if the time for reformatting is less than the time for retyping.

1. Select one column of content (two columns won’t work since the separator column is in the template) and copy it.

copy1

2. Go to the label template, click in one cell, and paste. The pasted content will fit into the label template, taking on the correct dimensions.

copy2

3. To apply the correct formatting (you can do this after you’ve pasted all the content), select the pasted content and from the styles dropdown list, select Default.

copy3

4. With the pasted content still selected, choose Format > Paragraph, click the Indents & Spacing tab, and specify .07 inch in the first two fields.

copy4

5. Click OK.

Note: You could also update the Default style to be indented .07 from each side.

Pasting One Cell Into Multiple Label Cells

Let’s say you’re making moving labels, or business cards, or something else where you need exactly the same information in every cell. Rather than pasting into each cell individually, you can copy the text once, then paste into every cell.

1. Select the content to paste, as plain text. You don’t need it to be a table cell.

2. Go to the labels and select all the cells where you want that text to show up.

3. Paste. The content will appear in every selected cell.

Again, you’ll need to apply the Default style as before, and as before, only paste a column at a time because of the separator columns.

Copying the First Page to Make Additional Pages

If you want to make a multi-page sheet of labels, here’s how. You essentially just select the whole table and paste it onto the next page.

1. Select the whole table. You can simply click in the upper right cell and drag down to the lower right cell, or click in one of the cells and press Ctrl A.

2. Copy the table.

3. Click below the table.

twopages

4. Paste. The table will appear on the next page. Repeat these steps to add additional pages.

Using Label Wizard Templates

There are two basic types of label templates in OpenOffice.org: documents that already exist, and templates that are created for you based on selections you make in the label wizard. Using the wizard labels is a bit different. It’s definitely a good idea to learn to use them, however; they provide two key features, mail merge and the ability to automatically update all labels in the sheet to match the first label. I won’t talk about mail merge, since that’s a big topic on its own, but I will go through how to do the automatic update, also known as synchronizing.

Creating a Label Using the Label Wizard

1. Choose File > New > Labels.

2. In the window that appears, select the page size and Avery number that you want.

3. If you want the same content to appear in every label, fill in that text in the blank field. (You can change and format it later.)

labelwindow_callouts

Note: If you want to make slight adjustments to the label, click the Format tab and change the measurements. However, this is an advanced task and you shouldn’t have to do this.

4. Click the Options tab. If you want the text or formatting to be the same in all the labels, select the Synchronize option.

labelswindow_optionstab

5. Click New Document. The label document will appear, and if you selected Synchronize, the Synchronize button will appear, as well.

labelsdocument

6. You’re now ready to format, print, edit, or otherwise change the template.

Updating Labels Using the Synchronize Feature

Here’s how the Synchronize feature works. It’s very handy—you can use it to update the text or the formatting (or the graphics) in the first label so that all other labels match.

1. Make the changes you want in the first cell. Change the formatting as you would normally in a text document, change the content, or (as in the next procedure) add a graphic.

synch1

2. Click the Synchronize Labels button.

3. All the labels will be updated to match the first one.

synch2

– creating in the wizard
– using synchronize
– saving as a template with File > Templates > Save to put in the category with the others

Saving a Wizard Template as a Standard Template

Going through the Wizard to create labels each time is a bit more work than just opening an existing template. However, there is that handy Synchronize feature. What do you do to reduce the labor associated with the wizard labels? Just save the template the wizard creates in the same location as your other templates.

1. Create a template as you would normally, through the wizard.

2. Do any additional formatting once you have created the template.

3. Choose File > Templates > Save.

4. In the Templates window that appears, type a name for the template, and a category.

templates_save

Note: To create a new category, click Organizer. In the left-hand list, right-click on an existing category and select New. Immediately type the name of the new category. Click Close to go back to the Templates window.

5. Click OK.

You can now use the template the same way you use any other template. Choose File > New > Templates and Documents, select the Templates category, and just double-click the template you want.

Adding Graphics to Any Template

A major feature of OpenOffice.org templates is the ability to add graphics. You can add them in the corner, or in the background as a watermark.

Inserting a Graphic

1. Just click in the cell where you want the graphic.

2. Choose Insert > Picture > From File.

3. Find the graphic on your computer and select it.

4. The graphic will appear.

pic_appears

5. To resize it, hold down Shift and drag one of the corner handles in or out.

pic_resize

Wrapping Text Around a Graphic

At this point, you’ve got a graphic but it probably doesn’t look that good with the text.

wrap1

To wrap the text nicely around the text, right-click on the graphic and choose Page Wrap.

wrap2

Now you can move the graphic and the text will get out of its way. If necessary, delete any new carriage returns that were created.

wrap3

Note: To specify a little more room around the graphic, right-click and choose Picture. In the Wrap tab, specify spacing.

Adding a Background Graphic

You can add a graphic to the background of each label, too. I’ll use this lightened watermark OpenOffice.org logo as an example.

ooo_watermark

First, format the text the way you want it, since with a background graphic the text will be harder to select.

Insert the graphic in the label the same way you do with other graphics, by choosing Insert > Picture > From File.

water1

Then right-click on the graphic and choose In Background.

water2

You’ll see the graphic in the background.

water3

Final Thoughts on Templates as Tools

No templates article would be complete without mentioning styles. Styles can make formatting templates even faster. Styles are a far bigger topic than templates, but I hope you’ll google for information, use the online help, or refer to the styles section of my blog, http://openoffice.blogs.com/openoffice/styles/index.html

I hope you’ll use templates, either the WorldLabel templates or the wizard templates or both, to make your job easier. It’s easy to fall into the habit of doing things manually, and I do that myself. But the difference when you take a little time to set up templates is amazing. It’s particularly helpful when you have a large team of people—the time you save yourself might not be that much but the time that five or 500 people save is tremendous. If you have new people on your team regularly, if consistency is a goal or a challenge for your organization, or if you have a distributed team, templates can be tremendously helpful. They’re the right tool for the job.

 

Bio

Solveig Haugland has worked as an instructor, course developer, author and technical writer in the high-tech industry for 15 years, for employers including Microsoft Great Plains, Sun Microsystems,and BEA. Currently, Solveig is a StarOffice and OpenOffice.org instructor, author, and freelance technical writer. She is also co-author, with Floyd Jones, of three books: Staroffice 5.2 Companion, Staroffice 6.0 Office Suite Companion and OpenOffice.Org 1.0 Resource Kit, published by Prentice Hall PTR. Her fourth book, on OpenOffice.org 2.0, is coming this fall. For more tips on working in OpenOffice, visit Solveig’s OpenOffice blog.

 

Comments

comments